Слободнији и бољи, Либреофис на српском

Информације о Јава окружењу

За неке функције пакета Либреофис неопходно је Јава окружење. Уколико користите Microsoft Windows, можете да бесплатно преузмете Oracle JavaSE JRE. Уколико користите 64-битни Windows оперативни систем, варијанта Јава окружења (32-битна или 64-битна) треба да одговара инсталираној варијанти програма Либреофис, без обзира на варијанту оперативног система. Више информација о разлици 32-битног и 64-битног Windows система потражите овде.

Либреофис 4.5 и ранији за Windows долази искључиво у 32-битној варијанти, коју потпуно једнако можете да користите и на 32-битним и на 64-битним системима, али је при томе неопходно да инсталирате 32-битну варијанту Јава окружења (са странице за преузимање, пратите линк Windows Offline). Не смета да на систему истовремено буду инсталиране и 32-битна и 64-битна варијанта Јава окружења ако вам је друга потребна ради других програма.

Либреофис 5.0 и новији постоји и у посебној 64-битној варијанти за 64-битни Microsoft Windows. У овом случају потребно је да инсталирате 64-битну варијанту Јава окружења (са странице за преузимање, пратите линк Windows Offline 64-bit)

Основне фунцкије Либреофиса не захтевају да инсталацију Јава окружења на рачунару.

Јава окружење у пакету Либреофису захтевају значајни делови програма Либреофис База (за рад са базама у датотеци без повезивања на посебни сервер, као и помоћници за израду упита, формулара и извештаја), други делови пакета који користе базе у датотеци (нпр. библиографија у текстуалним документима), подршка технологијама за испомоћ (читачи екрана и сл.), неки помоћници у другим деловима Либреофиса и филтери за читање ретких формата докумената (Pocket Word и Pocket Excel).

За коришћење оних Либреофис додатака (екстензија) који су писани у Јави и макроа у Јави/Beanshell-у или Јаваскрипту такође је потребна инсталација Јава окружења.

Ни за једну функцију у Либреофису није неопходна инсталација било каквих Јава аплета нити интеграција Јаве у веб прегледаче, тако да Либреофис није на удару недавних сигурносних пропуста у Јава аплетима.

На ГНУ/Линуксу препоручујемо инсталирање Либреофиса кроз систем пакета дистрибуције, а ако инсистирате на ручној инсталацији постоје проблеми са GCJ Java окружењем па саветујемо да користите OpenJDK JRE. Oracle JRE издање окружења је подједнако добро подржано.