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Predgovor 

 

Današnje društvo obilježeno je naglim rastom i razvojem informacijske tehnologije 

(IT), što je rezultiralo velikom ovisnošću društva, u širem smislu, o znanju i 

kompetencijama osobe u IT području. I premda ta ovisnost raste iz dana u dan, 

ljudsko pravo na obrazovanje i informacije nije prošireno i na IT područje. Pojavili 

su se problemi koji utječu na društvo u cjelini, koji stvaraju prepreke i udaljavaju 

ljude od glavnog razloga i motivacije za napredak, od prilike. Biti računalno 

nepismena osoba, danas znači biti osoba koja nije u mogućnosti sudjelovati u 

modernom društvu, biti osoba bez prilike. Unatoč priznanju Europske komisije, 

UNESCO-a, OECD-a i ostalih relevantnih institucija o neophodnosti i korisnosti 

informatičke pismenosti, još uvijek postoje grupe ljudi s otežanim pristupom 

osnovnoj računalnoj naobrazbi (npr. osobe s invaliditetom, osobe s poteškoćama 

u učenju, radnice/i migranti, nezaposlene osobe, osobe koje žive na udaljenim 

mjestima gdje nemaju pristup računalnoj edukaciji). 

Ovaj priručnik, zajedno s ostalim materijalom objavljenim na stranici ITdesk.info, 

predstavlja naš doprinos realizaciji i promociji ljudskog prava na edukaciju  

i informacije u IT području. Nadamo se da će Vam ova edukacija pomoći u 

savladavanju osnovnih računalnih vještina i s tom nadom želimo Vam da naučite 

što više i tako postanete aktivni/a član/ica modernog IT društva. 

Iskreno Vaši, 

ITdesk.info team  
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1. OBLIKOVANJE 

1.1 ĆELIJE 
 

Primijeniti automatsko oblikovanje/stil tablice na raspon ćelija 

 Označiti željene ćelije (moraju biti označena minimalno 3 retka i stupca, uključujući 
zaglavlja) 

 Otići na Format -> AutoFormat kako bi se otvorio AutoFormat dijaloški okvir 

 Na dijaloškom okviru potom odabrati željeno oblikovanje 

 

 

 
 

Primijeniti uvjetno oblikovanje bazirano na temelju sadržaja ćelije 

 
Kreirati i primijeniti prilagođeno oblikovanje brojeva 

Ponekad je podatke potrebno oblikovati na način da se oblikovanje mijenja ovisno o nekom 
uvjetu koji je prije zadan. To vam primjerice omogućava da nekom drugom bojom označite 
određene brojeve koji za vas imaju posebno značenje (npr. temperature više od prosječnih). 
Kako bi se primijenilo uvjetno oblikovanje potrebno je najprije se osigurati da je uključen 
AutoCalculate: Tools -> Cell Contents -> AutoCalculate. 

 Označiti ćelije, odnosno raspon ćelija nad kojima se želi primijeniti uvjetno 
oblikovanje 

 Format -> Conditional Formatting -> Condition 

 Na dijaloškom okviru će se prikazati sva već postojeća uvjetna oblikovanja (ukoliko 
postoje) 

 Kliknite na Add kako biste definirali novi uvjet 
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 Odabrati željeni uvjet te stil koji će se primijeniti (moguće je kreirati i vlastiti stil). 

 Uvjetno formatiranje osim Condition, nudi i Color scale i Data bars (odabiru se na isti 
način kao i Condition). Color scale koristite kada želite postaviti pozandinsku boju 
ćelije ovisno o nekoj vrijednosti u ćeliji. Ovu je opciju moguće koristiti samo onda 
kada se uvjet primjenjuje na sve ćelije. Data bars nudi grafičku reprezentaciju 
podataka. Također se može koristiti samo onda kada se uvjet primjenjuje nad svim 
ćelijama. 

 

 

 

1.2 RADNI LIST 
 

Kopirati, premještati radne listove između radnih knjiga 

Odabir radnih listova: 

 1 radni list odabirete tako da jednostavno kliknete na njegovu karticu u dnu radnog 
lista 

 Više uzastopnih listova odabirete tako da kliknete na karticu s imenom prvog radnog 
lista kojeg želite označiti, pomaknete se mišem na zadnji radni list u nizu kojeg želite 
označiti te pritisnete tipku Shift + klik mišem na karticu. Kartice označenih listova će 
promijeniti boju u bijelu. 

 Više ne uzastopnih listova odabirete tako da kliknete na karticu sa imenom prvog 
radnog lista kojeg želite označiti te klikate na kartice ostalih listova istodobno držeći 
pritisnutom tipku Ctrl. Kartice označenih listova će promijeniti boju u bijelu. 

 Kako biste odabrali sve radne listove, kliknete desnom tipkom miša na bilo koju 
karticu te odaberite Select All Sheets opciju. 
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Za kopiranje/premještanje radnih listova potrebno je označiti željene listove pa otići na Edit -
> Sheet -> Move/Copy. Otvorit će se dijaloški okvir u kojem potom možete definirati da li 
listove želite kopirati ili ih želite premjestiti. Također možete definirati da li želite 
kopirati/premjestiti u istu radnu knjigu ili u drugu, te na koje mjesto unutar radne knjige 
želite kopirati/premjestiti radne listove. 

 

 

NAPOMENA: Kada stvorite kopiju radnog lista, stvara se duplikat radnog lista u odredišnoj 
radnoj knjizi. Kada radni list premjestite, on se uklanja iz izvorne radne knjige i pojavljuje se 
samo u odredišnoj radnoj knjizi. 

 

 

Podijeliti prozor. Premjestiti, ukloniti podjelu prozora 

Prozor se može podijeliti okomito, vodoravno ili i okomito i vodoravno. 

Okomita ili vodoravna podjela 

- Označiti redak ispod retka u kojeg želite ubaciti podjelu, odnosno označiti 

stupac poslije stupca u kojeg želite ubaciti podjelu. 

- Window -> Split 

Okomita i vodoravna podjela (podjela na 4 dijela) 

- Označiti ćeliju koja se nalazi ispod retka gdje želite postaviti podjelu, i koja 

se ujedno nalazi desno od kolone u kojoj želite postaviti podjelu. 

- Window -> Split 
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Podjela se u oba slučaja uklanja tako da opet odete na Window -> Split. 

Za premještanje podjele je dovoljno kliknuti na liniju podjele te ju povući na željenu stranu. 

 

Sakriti, prikazati retke, stupce, radne listove 

U Calc-u možete sakriti elemente tako da ne budu vidljivi na zaslonu računala, niti prilikom 
ispisa. Međutim, skriveni elemente se i dalje mogu označavati kod kopiranja ukoliko označite 
elemente koje ih okružuju. Primjerice, ako je redak B skriven, on će biti označen kada 
odaberete retke A i C.  

Skrivanje: 

- Odabrati stupac/redak/radni list kojeg želite sakriti 

- Format -> pa odabrati Sheet, Row ili Column, ovisno što ste odabrali za 

sakrivanje -> Hide 

Prikazivanje: 

- Označiti susjedne retke/kolone/radne listove 

- Format -> Sheet/Row/Column -> Show (ili desni klik mišem pa Show) 
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2. FUNKCIJE I FORMULE 

Funkcije su unaprijed definirane formule koje izvode izračune pomoću određenih vrijednosti 
koji se zovu argumenti, u nekom točno zadanom redoslijedu ili strukturi. Pomoću funkcija 
mogu se izvoditi razni izračuni. 

Korištenje funkcija i formula TODAY, NOW, DAY, MONTH, YEAR 

Koristiti funkcije datuma i vremena: TODAY, NOW, DAY, MONTH, YEAR. 

- TODAY() -> vraća trenutni datum. Ukoliko odaberete neku ćeliju i u traku formula 

unesete =TODAY() u ćeliji će biti prikazan trenutni datum. 

- NOW() ->  vraća trenutni datum i vrijeme. Ukoliko odaberete neku ćeliju i u traku 

formula unesete =NOW() u ćeliji će biti prikazan trenutni datum i trenutno vrijeme. 

- DAY(number) -> Redni broj je datum čiji dan pokušavate pronaći. Ukoliko recimo u 

ćeliju A1 pomoću funkcije TODAY() pohranite trenutni datum, i onda označite ćeliju 

A2 i u traku formula unesete =DAY(A1) dobit će dan u mjesecu (vrijednost od 1 do 

31). 

- MONTH(number) i YEAR (number) rade na istom principu kao DAY samo što MONTH 

vraća broj koji predstavlja mjesec, a YEAR vraća godinu. 

 

Koristiti matematičke funkcije: ROUNDDOWN, ROUNDUP, SUMIF 

- ROUNDDOWN(number; count) -> zaokružuje broj na niži broj bliži nuli. Prima 2 

argumenta, a to su broj kojeg se želi zaokružiti na nižu vrijednost i broj znamenki na 

koji se broj želi zaokružiti. 

 Ako je broj_znamenki veći od 0 (nula), broj se zaokružuje na dolje na navedeni broj 

decimalnih mjesta. 

 Ako je broj_znamenki jednak 0, broj se zaokružuje na najbliži cijeli broj. 

 Ako je broj_znamenki manji od 0, broj se zaokružuje prema dolje na navedeni broj 

mjesta s lijeve strane decimalnog zareza. 

Primjeri: 

=ROUNDDOWN(5.8; 0) -> zaokružuje na manji broj tako da nema decimalnih mjesta 
pa će rezultat biti 5. 

=ROUNDDOWN(5.123456; 3) -> zaokružuje zadani broj na 3 decimalna mjesta pa će 
rezultat biti 5.123 

- ROUNDUP(number; count) -> zaokružuje na broj udaljeniji od o. Prima 2 argumenta, 

a to su broj kojeg se želi zaokružiti na višu vrijednost i broj znamenki na koji se broj 

želi zaokružiti. 

 Ako je broj_znamenki veći od 0 (nula), broj se zaokružuje prema gore na navedeni 

broj decimalnih mjesta. 

 Ako je broj_znamenki jednak 0, broj se zaokružuje na najbliži cijeli broj. 
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 Ako je broj_znamenki manji od 0, broj se zaokružuje prema gore s lijeve strane 

decimalnog zareza. 

Primjeri: 

=ROUNDUP(52.4; 0) -> zaokružuje broj na veći tako da nema decimalnih mjesta pa je 
rezultat 53 

=ROUNDUP(3.14182; 3) -> zaokružuje broj na 3 decimalna mjesta pa je rezultat 
3.142. 

- SUMIF(range, criteria, sum_range) -> koristi se za zbrajanje vrijednosti u rasponu 

koje zadovoljavanju navedene kriterije. Primjerice ukoliko u nekom stupcu želite 

zbrojiti samo brojeve koju su manji od 9 formula bi glasila =SUMIF(C1:C15, “<9“). 

Prima 2 obavezna argumenta, a to su raspon ćelija na koje želimo da se funkcija 

odnosi i kriteriji u obliku broja, izraza, reference ćelije, teksta ili funkcije koja definira 

koje će ćelije biti dodane. Neki primjeri kriterija su 15, „>12“, D2, „student“ ili 

TODAY(). Dodatno prima i raspon_zbroja koji nije obavezan. Predstavlja stvarne ćelije 

koje je potrebno dodati ako želite dodati neke druge ćelije osim onih određenih u 

argumentu raspona. Ako je argument raspon_zbroja izostavljen, Calc zbraja ćelije 

koje su određene u argumentu raspon (iste ćelije na koje se primjenjuju kriteriji). 

 

 

 

U ovom smo slučaju sa formulom =SUMIF(A2:A5, "Igračke", C2:C5) rekli da želimo dobiti 
zbroj svih cijena za proizvode koji spadaju u kategoriju Igračke. 

 

Koristiti statističke funkcije: COUNTIF, COUNTBLANK, RANK. 

- COUNTIF(range, criteria) -> prebrojava ćelije unutar raspona koje ispunjavaju jedini 

kriterij koji odredite.  Prima 2 obavezna argumenta, a to su raspon ćelija koje je 

potrebno prebrojati i kriterij odnosno broj, izraz, referenca ćelije ili tekstni niz koji 

definira koje će se ćelije prebrojavati. Ukoliko primjerice želimo prebrojati koliko se 

puta u nekom stupcu pojavljuje broj 10 tada ćemo to zapisati =COUNTIF(A2:A20; 10). 

Ako se broj 10 pojavio u 3 ćelije taj ćemo broj dobiti kao rezultat. 

- COUNTBLANK(range) -> prebrojava prazne ćelije u navedenom rasponu. Prima samo 

jedan obavezan argument, a to je raspon. Ukoliko primjerice želimo prebrojati koliko 

se puta pojavljuje prazna ćelija u nekom rasponu tada ćemo to zapisati 
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=COUNTBLANK(A2:A20). Ako su bile 4 prazne ćelije tada ćemo taj broj dobiti kao 

rezultat. 

- RANK(value, data, type) -> vraća položaj broja u popisu brojeva. Položaj broja je 

njegova relativna veličina u odnosu na ostale vrijednosti u popisu, odnosno kada bi 

na to gledali kao na sortiranje, tada bi položaj broja bila njegova pozicija. Prima 3 

obavezna argumenta, a to su broj čiji položaj želite pronaći, data odnosno polje 

popisa brojeva ili referenca na popis brojeva te redoslijed odnosno broj koji određuje 

kako odrediti položaj broja. Ako je argument redoslijed 0 ili je izostavljen tada se 

rangiranje vrši kao da je argument data sortiran silazno, u suprotnom se rangiranje 

vrši kao da je argument data sortiran uzlazno. 

 

Koristiti tekstualne funkcije: LEFT, RIGHT, MID, TRIM, CONCATENATE 

- LEFT(text, number) -> vraća prvi znak ili znakove s lijeve strane (s početka teksta) u 

tekstualnom nizu na temelju broja znakova koji se odredi. Prima 2 argumenta od 

kojih je tekst obavezan i odnosi se na tekstualni niz koji sadrži znakove koje želite 

izdvojiti te broj znakova koji nije obavezan, a određuje broj znakova koje će funkcija 

izdvojiti. Ako se broj_znakova navede mora biti veći ili jednak nuli. Ako je veći od 

duljine teksta vraća se cjelokupni tekst, ako se broj znakova izostavi pretpostavlja se 

da je 1. 

Ako u ćeliji A1 imamo tekst „Excel“ i napišemo =LEFT(A1,2) dobit ćemo kao rezultat Ex. 

- RIGHT(text, number) -> radi isto što i LEFT samo što vraća prvi znak ili znakove sa 

desne strane (sa kraja teksta). 

- MID(text, start, number) -> funkcija vraća određeni broj znakova iz tekstualnog niza 

počevši od mjesta koje navedete na temelju određenog broja znakova. Prima 3 

obavezna argumenta, a oni su tekst koji sadrži znakove koje se želi izdvojiti, početni 

broj, odnosno mjesto prvog znaka kojeg se želi izdvojiti iz teksta te broj znakova 

odnosno broj znakova koje želite da funkcija MID vrati. 

 Ako je argument početni broj veći od dužine teksta, funkcija MID vraća "" (prazan 

tekst). 

 Ako je početni broj manji od duljine teksta, a zbroj argumenata početni broj i broj 

znakova premašuje duljinu teksta, funkcija MID vraća znakove do kraja teksta. 

 Ako je argument početni broj manji od 1, funkcija MID vraća pogrešku #VALUE!. 

 Ako je argument broj znakova negativan, funkcija MID vraća pogrešku #VALUE!. 

Pretpostavimo da  u ćeliji F1 imamo tekst „Matematika“. Ukoliko napišemo funkciju 
=MID(F1,3,4) kao rezultat ćemo dobiti „tema“. 

- TRIM(text) -> uklanja sve razmake iz teksta, osim jednostrukih razmaka između riječi. 

Prima samo jedan obavezan argument, a to je tekst iz kojeg se žele ukloniti razmaci. 
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Da u ćeliji A1 imamo tekst „    Danas je lijep dan“, sa funkcijom =TRIM(A1) kao 
rezultat bi dobili „Danas je lijep dan“, odnosno bili bi uklonjeni razmaci s početka 
teksta. 

- CONCATENATE(text1, text2 ...) -> funkcija koja spaja više tekstualnih nizova u jedan 

tekstualni niz. Spajati se mogu tekstovi, brojevi, reference na ćelije ili kombinacija 

navedenog. Prima jedan obavezni parametar, text1, i to je prvi niz kojeg se treba 

spojiti. Ostali su parametri opcionalni i predstavljaju ostale nizove koje želite spojiti. 

Ukoliko primjerice u jednom stupcu imamo imena učenika, a u drugoj njihova 
prezimena, puno ime i prezime možemo dobiti sa =CONCATENATE(A1," ",B1). Drugi 
argument u ovom primjeru je (" ") odnosno razmak. Obavezno je navoditi razmake i 
punktacijske znakove koje želite da se pojave u konačnom rezultatu. Znak & je 
ekvivalentan funkciji CONCATENATE, pa = A1 & B1 vraća isto što i = 
CONCATENATE(A1, B1) 

 

 

Koristiti financijske funkcije: FV, PV, PMT 

FV(Rate, NPer, Pmt, PV, Type) -> vraća buduću vrijednost ulaganja na temelju periodične, 
konstantne otplate i kamatne stope.  

 Rate – obavezno. Kamatna stopa po razdoblju. 

 NPer – obavezno. Ukupan broj razdoblja plaćanja anuiteta. 

 Pmt - Otplata u svakom razdoblju; ne može se mijenjati tijekom trajanja anuiteta. 

Rata obično sadrži glavnicu i kamate bez dodatnih poreza i pristojbi. Ako izostavite 

ratu, morate upisati argument PV.  

 PV - neobavezno. Sadašnja vrijednost, odnosno ukupni zbroj iznosa sadašnjih 

vrijednosti niza budućih plaćanja. Ako se PV izostavi, pretpostavlja se da je 0 (nula), a 

morate navesti argument Pmt. 

 Vrsta - neobavezno. Broj 0 ili 1 i naznačuje kada se obavljaju uplate. Ako se vrsta 

izostavi, pretpostavlja se da je 0, što znači da se uplate vrše na kraju perioda. 1 

označava da se uplate vrše na početku perioda. 

Primjer: pretpostavimo da na računu imate 500 kn (to je sadašnja vrijednost), te da želite to 
oročiti na 5 godina uz godišnju kamatnu stopu od 2.5%. Na kraju svakog mjeseca ćete još 
uplaćivati 200 kn. 

Ukoliko unesemo =FV(2.5%/12, 5*12, -200, -500) kao rezultat dobijemo 13 334,61 kn. Dakle 
za 5 godina će vrijednost na računu iznositi 13 334,61. Kamatnu stopu smo podijelili sa 12 jer 
se otplate vrše mjesečno, dok je broj godina pomnožen sa 12 kako bi se dobio broj mjeseci 
otplate. Pmt i PV imaju negativan predznak jer predstavljaju davanja. 

PV(Rate, NPer, Pmt, FV, Type) -> vraća trenutnu vrijednost ulaganja. . Sadašnja vrijednost je 
ukupan iznos sadašnje vrijednosti niza budućih novčanih izdataka. Argumenti koje prima su 
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isti kao za funkciju FV uz razliku da ne prima argument PV već FV koji označava buduću 
vrijednost ili saldo koji želite postići nakon posljednje uplate.  FV se može izostaviti, ali se 
onda obavezno mora navesti iznos rate. 

Primjer: pretpostavimo da želimo saznati koliko bismo trebali uplatiti danas kako bismo 
nakon 4 godine uz 8% godišnje kamatne stope te uz mjesečna primanja od 500 kn na računu 
ostalo 20 000 kn. 

Ukoliko unesemo  =PV(8%/12;48;500;20000) kao rezultat bismo dobili -35 019,37 kn. To 
znači da bismo danas morali uplatiti taj iznos kako bismo 4 godine mjesečno primali po 500 
kn, a da nam na kraju ostane 20 000,00 kn na računu. Otud i negativan predznak, jer 35 
019,37 kn predstavlja izdatak. 

PMT(Rate, NPer, PV, FV, Type) -> funkcija koja služi za određivanje rate otplate kredita na 
temelju kamatne stope i periodične, konstantne otplate. Prima 5 argumenata, od čega su 
prva 3 obavezna. Rate, Nper, i vrsta  imaju isto značenje kao za prethodne 2 funkcije. PV je 
sadašnja vrijednost ili glavnica. FV je opcionalan te predstavlja buduću vrijednost, ukoliko se 
ne navede podrazumijevana vrijednost je 0.  

Primjer: ukoliko godišnja kamatna stopa iznosi 7.5%, otplatu vršimo u razdoblju od 2 godine, 
trenutna vrijednost iznosi 5000 kn uz funkciju =PMT(7.5%/12, 2*12, 5000, 0, 1) dobili bismo 
iznos rate 223.60 kn. 

 

Koristiti funkcije za reference i pretraživanja: VLOOKUP, HLOOKUP. 

VLOOKUP(SearchCriteron, Array, Index, SortOrder) -> ova funkcija obavlja vertikalno 
pretraživanje, odnosno pretraživanje po stupcima. Kao argumente prima vrijednost po kojoj 
se radi pretraživanje, niz stupaca koje se pretražuje, indeks odnosno redni broj stupca iz 
kojeg se želi dobiti kao povratna vrijednost, vrijednost koja se nalazi u istom retku kao 
vrijednost koja se prosljeđuje. SortOrder je opcionalan i ukazuje na to da li je prvi stupac u 
nizu sortiran uzlazno. Ukoliko ga se ne navede, ili ukoliko je TRUE ili 1, pretpostavlja se da su 
podaci sortirani uzlazno. U ovom slučaju ukoliko funkcija ne pronađe točno podudaranje 
vratit će prvu najveću vrijednost koja po redoslijedu dolazi prije tražene vrijednosti (odnosno 
da smo recimo tražili vrijednost 20, a ona ne postoji, vratit će najbližu manju vrijednost od 
tražene, tj. da je recimo postojala vrijednost 19 nju bi dobili kao povratnu vrijednost). 
Ukoliko se za SortOrder stavi FALSE ili nula, tada ukoliko funkcija ne pronađe točno 
podudaranje kao rezultat vraća grešku „Error: Value Not Available“. 

 

 
 

Na gornjoj slici je prikazan primjer u kojem u jednom stupcu imamo šifre, a u drugom imena 
proizvoda. Recimo da želite saznati koji se proizvod nalazi pod šifrom 3, unijeli biste 
=VLOOKUP(3, A1:B4, 2) te bi kao povratnu vrijednost dobili Bomboni. 
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U gornjem slučaju se traži proizvod pod šifrom 3 koji ne postoji. Obzirom da smo naveli da je 
prvi stupac sortiran uzlazno (TRUE u šifri) funkcija će nam vratiti 2, odnosno prvu najveću 
vrijednost koja je manja od tražene vrijednosti. 

HLOOKUP(SearchCriteron, Array, Index, SortOrder) -> radi isto što i VLOOKUP samo što se 
pretraživanje vrši po recima. 

 

 

Koristiti funkcije baze podataka: DSUM, DMIN, DMAX, DCOUNT, DAVERAGE 

DSUM(Database, DatabaseField, SearchCriteria) -> zbraja brojeve koji zadovoljavaju 
određene uvjete. 

Sva 3 argumenta koja prima su obavezna, a oni su: Database, odnosno raspon ćelija koji čin 
popis ili bazu podataka, DatabaseField je stupac koji se koristi u funkciji, a SearchCriteria je 
raspon ćelija koji sadrži uvjete koje ste odredili. 

Primjer: za donju tablicu, ukoliko bismo pozvali funkciju =DSUM(A4:D8,C4,A1:B2) dobili 
bismo kao rezultat 9, odnosno zbroj cijena po jedinici za sve narudžbe koje imaju redni broj 
preko 10 i u kojima je količina veća ili jednaka 3. 

 

 

DMIN(Database, DatabaseField, SearchCriteria)-> prikazuje najmanji broj u polju (stupcu) 
zapisa na popisu ili u bazi podataka koji zadovoljava određene uvjete. Argumenti koje prima 
su isti kao funkcija DSUM. Ako bi nad gornjom tablicom pozvali funkciju 
=DMIN(A4:D8,C4,A1:B2) kao rezultat bi dobili 4, odnosno najmanju cijenu po jedinici. 

DMAX(Database, DatabaseField, SearchCriteria) -> Prikazuje najveći broj u polju (stupcu) 
zapisa na popisu ili u bazi podataka koji zadovoljava određene kriterije. Vrijedi sve navedeno 
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za DSUM i DMIN. Ukoliko bi nad gornjom tablicom pozvali =DMAX(A4:D8,C4,A1:B2) kao 
rezultat bi dobili 5, odnosno najveću cijenu po jedinici. 

DCOUNT(Database, DatabaseField, SearchCriteria)-> Broji ćelije koje sadrže brojeve u polju 
(stupcu) zapisa na popisu ili u bazi podataka koje zadovoljavaju određene uvjete.  I za nju 
vrijedi sve navedeno za ranije funkcije pa bi poziv =DCOUNT(A4:D8,C4,A1:B2) vratio broj 2, 
odnosno da 2 ćelije odgovaraju zadanim kriterijima. 

DAVERAGE(Database, DatabaseField, SearchCriteria)-> Određuje prosjek za vrijednosti u 
polju (stupcu) zapisa na popisu ili u bazi podataka koje zadovoljavaju određene uvjete. I za 
nju vrijedi sve ranije navedeno pa bi poziv =DAVERAGE(A4:D8,C4,A1:B2) vratio 4.5 odnosno 
podijelio bi ono što je vratio DSUM sa onim što je vratio DCOUNT u ovom slučaju. 

 

Koristiti ugniježđene funkcije druge razine 

Ponekad imamo potrebu koristiti neku funkciju kao argument koji se prosljeđuje drugoj 
funkciji. To se naziva ugnježđivanjem.  

Kada se Funkcija B koristi kao argument Funkcije A, Funkcija B je funkcija druge razine. 
Primjer ugniježđene funkcije druge razine bi bio = ROUND(SUM (D1 : D3), 2). Tu funkcija 
ROUND prima kao prvi argument ono što vraća funkcija SUM. 

 

Koristiti 3-D reference u funkciji zbroja 

3-D reference nam omogućavaju istovremeno referenciranje ćelije na više radnih listova.  

=SUM(Sheet2:Sheet13.B5) -> vraća zbroj svih vrijednosti sadržanih u ćeliji B5 na svim radnim 
listovima između 2 i 13, uključujući ta 2 lista. 

=SUM(Sheet1:Sheet10.A1:C3) -> vraća zbroj svih vrijednosti u ćelijama u rasponu A1:C3 u 
radnim listovima između 1 i 10, uključujući ta 2 lista. 

 

Koristiti mješovite reference u formulama 

Mješovite reference nam omogućavaju kombiniranje jedne apsolutne i jedne relativne 
oznake bilo da se radi o oznaci stupca ili oznaci retka. Relativne reference su one koje će se 
promijeniti ako ćeliju s formulom u kojoj su korištene kopiramo na drugu lokaciju. One su 
definirane samo oznakom stupca i retka (npr. A1, B3). Apsolutne reference su one koje 
prilikom kopiranja ili  premještanja formule uvijek referenciraju istu ćeliju. Označavaju se 
tako da se uz oznaku stupca i retka referencirane formule stavlja znak dolara ($) (npr. $A$1). 

Imamo 2 podvrste mješovitih referenci: 

 Apsolutni stupac – relativni redak. Primjer takve reference je $A3. Kod ovih referenci 

se prefiks $ nalazi ispred slova koji označava stupac. Ako formulu sa ovakvom 

referencom kopiramo, promjenom ćelije u kojoj se nalazi formula promijeniti će se 

samo adresa retka. Ako smo formulu u kojoj koristimo gornju referencu $A3 kopirali 

jedan redak ispod i jedan stupac desno od onoga u kome se nalazi originalna formula, 

referenca će se promijeniti u $A4. 

 Relativni stupac- apsolutni redak. Primjer takve reference je A$2. U ovom slučaju 

kopiranjem formule mijenja se adresirani stupac dok adresa retka ostaje uvijek ista.  
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3. GRAFIKONI 

3.1 KREIRANJE GRAFIKONA 
 

Kreirati kombinirani linijsko-stupčasti grafikon 

 
U tablici najprije označite sve podatke koje želite prikazati u grafikonu (za ovaj primjer će biti 
označena cijela tablica). 

 

Uspjeh Matematika Hrvatski Povijest 

Odličan 5 6 8 

Vrlo dobar 7 7 10 

Dobar 10 8 4 

Dovoljan 5 5 4 

Nedovoljan 3 4 4 

 

Nakon toga odete na Insert -> Object -> Chart. U tom trenutku će se pokrenuti čarobnjak za 
grafove, na kojem možete odabrati linijsko stupčasti grafikon. 
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Calc će implicitno uzeti podatke iz zadnjeg stupca i njih prikazati linijski. Ukoliko želite da 
recimo Matematika bude prikazana linijski, a ostala 2 predmeta u stupcima tada je potrebno 
označiti graf te potom Format -> Data Ranges te klikanjem na strelicu označenu na slici 
pomaknuti podatke iz Matematike na zadnje mjesto. 

 

 

 

Dodati sekundarnu os na grafikon 

Moguće je dodati sekundarnu X, sekundarnu Y os ili obje. 

Označiti graf te desni klik miša i Insert/Delete Axes. 

Otvorit će se dijaloški okvir u kojem potom možete odabrati što želite dodati. 
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Promijeniti vrstu grafikona za definirani niz podataka 

Označiti željeni graf te desni klik miša i potom odabrati Chart Type. Pokrenut će se tako 
Čarobnjak za grafove u kojem možete promijeniti graf. 

 

Dodati, brisati niz podataka u grafikonu 

Desni klik miša na graf te odabrati Data Ranges. U dijaloškom okviru kliknuti na Remove 
kako biste obrisali niz podataka ili Add kako biste dodali niz podataka. Kod dodavanja niza 
podataka potrebno je definirati ime niza te raspon na X i Y osi (vidi sliku pod Kreirati 
kombinirani linijsko-stupčasti grafikon). 

 

3.2 OBLIKOVANJE GRAFIKONA 

 

Promijeniti položaj naslova grafikona, legende, naslova podataka 

Za izmjenu svojstava elemenata potrebno je označiti željeni element (primjerice naslov) te 
potom desni klik miša. U izborniku koji se pojavi odabrati Position and Size. 

 

 

 

 

Promijeniti vrijednosti na osi: minimalni, maksimalni broj za prikaz, glavni interval 

Označiti željenu os pa desni klik miša. Izabrati opciju Format Axis. 

U izborniku koji će se pojaviti odabrati karticu Scale, u kojoj potom možete odrediti 
minimum, maksimum te glavni interval. 
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Promijeniti prikaz vrijednosti jedinica na osi bez mijenjanja izvora podataka: stotice, 

tisućice, milijuni 

Ovo se postiže na isti način kako je opisano u odjeljku Promjena vrijednosti na osi. Ukoliko 
želimo prikazati vrijednosti u stoticama dodat ćemo jednu 0, za 1000 2 nule itd. 

 

 

 
 

Oblikovati stupce, trake, područje crtanja, područje grafikona za prikaz slike 

Za izmjenu svojstava elemenata potrebno je označiti graf te potom otići na Format -> željeni 
element. 
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4. ANALIZA 

4.1 KORIŠTENJE TABLICA 
 

Kreirati, izmijeniti zaokretnu tablicu 

Zaokretna tablica je specijalni tip tablice koji omogućava jednostavno sažimanje, analiziranje 
i prezentiranje podataka. 

Za kreiranje pivot tablice otići na Data -> Pivot table -> Create. U prvom dijaloškom okviru 
koji će se pojaviti birate izvor svoji podataka.  

 

 

U slijedećem koraku u dijaloškom okviru birate razmještaj podataka u zaokretnoj tablici: 

 

 

 
Polja možete povlačiti kako želite. Ukoliko primjerice želimo vidjeti koliko je ljudi putovalo u 
koju državu, kreirat ćemo novi redak za svaku državu na način da povučemo polje Država u 
Row Fields dio dijaloškog izbornika, te Osoba u Data fields. 

Calc u zaokretnim tablicama implicitno dodaje zbrojeve. To u ovom slučaju nije moguće kada 
imamo imena, pa moramo napraviti malu prilagodbu. Kada smo povukli Osoba u Data Fields, 
pojavilo se dugme na kojem piše „Sum – Osoba“, da bi to izmijenili potrebno je kliknuti na to 
dugme te kada se otvori dijaloški okvir odabrati Count. Na ovaj način smo definirali da ne 
želimo zbrojiti osobe, već da ih želimo izbrojiti. Rezultat toga je slijedeća tablica, u kojoj smo 
dobili ukupan broj osoba koje su putovale u određenu državu. Na isti smo način mogli dobiti 
statistiku po razlozima putovanja. 
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Za izmijeniti zaokretnu tablicu je dovoljno kliknuti desnom tipkom miša unutar nje te 
odabrati Edit Layout opciju. 

 
 

Izmijeniti izvor podataka i osvježiti zaokretnu tablicu 

Osvježavanje izvora podataka -> kliknuti unutar tablice pa desni klik miša i odabrati Refresh. 

Za izmjenu izvora podataka -> kliknuti unutar tablice te desni klik miša pa Edit Layout. U 
dijaloškom okviru koji se pojaviti kliknuti na More. 

 

 

 

Te nakon toga u Selection from unijeti novi izvor. 

 

 

 
 

Filtrirati, sortirati podatke u zaokretnoj tablici 

Podaci su u zaokretnoj tablici automatski sortirani rastuće. Sortiranje možete promijeniti: 

- Kliknuti na strelicu prema dolje koja se nalazi u zaglavlju stupca te odabrati drugačije 

sortiranje 
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- Sortirati automatski odabirom opcija Data Field Options. Kako bi došli od ovog 

izbornika trebate kliknuti unutar tablice pa desni klik miša i Edit Layout. U tom 

dijaloškom okviru dvaput kliknuti na redak/stupac kojeg želite urediti. Otvorit će se 

dijaloški okvir Data Field. Unutar njega kliknuti na Options. 

 

 

Za filtriranje podataka je potrebno kliknuti na ćeliju koja sadrži riječ Filter (automatski se 
kreira prilikom izrade zaokretne tablice) te potom ispuniti kriterije filtriranja po želji. 

 

 

 

Automatski, ručno grupirati podatke u zaokretnoj tablici/grafikonu i preimenovati grupe 

Grupiranje kategorija sa skalarnim vrijednostima 

- Potrebno je odabrati jednu ćeliju u kategoriju koju želite grupirati i otići na Data -> 

Group and Outline -> Group. U dijaloškom okviru koji se pojavi odrediti kriterije za 

grupiranje. 
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Na donjoj slici je za primjer uzeta tablica u kojoj imamo mjerenja brzina te njihovu 
frekvenciju pojavljivanja. 

 

 

Ukoliko u dijaloški okvir grupiranja unesete vrijednosti kako je to napravljeno na slici, tada će 
se grupiranje izvršiti u grupama sa intervalom od 5, odnosno rezultat će izgledati kao na 
slijedećoj slici. 

 

 

Grupiranje kategorija sa tekstualnim vrijednostima 

Za kategorije koje sadrže tekstualne vrijednosti nije moguće kreirati intervale. Više kategorija 
je moguće grupirati na način da označite željene kategorije te odete na Data -> Group and 
Outline -> Group. 

Za primjer su na tablici na slijedećoj slici označena prva tri odjela te je od njih napravljena 
jedna grupa. 
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Calc automatski dodjeljuje imena grupama. Za promjenu imena grupe označite ćeliju te u 
polje za unos vrijednosti unesite željeno ime grupe (moguće je da ćete nakon ovog morati 
osvježiti stranicu (desni klik miša pa Refresh)). 

 

 

Koristiti tablice sa jednom ili dvije ulazne varijable/višestruke operacije 

Tablice s jednom ulaznom varijablom -> bit će objašnjene kroz slijedeći primjer. Recimo da 
proizvodite igračke koje prodajete po 10 kn po komadu. Trošak izrade svake igračke je 2 kn. 
Uz to imate 10 000 kn fiksnih troškova godišnje. Pitanje koje se postavlja je koliko ćete 
zaraditi ukoliko u jednoj godini prodate određenu količinu igračaka. Za početak ćemo staviti 
2000 komada. U ćeliji B5 ćemo izračunati profit za tu količinu preko formule =Količina 
*(Prodajna cijena – Trošak po komadu) – Fiksni troškovi, =B4*(B1-B2)-B3. 

U kolonu D potom unesemo razne količine prodanih igračaka. 

 

Označite raspon D2:E11 te odite na Data -> Multiple Operations. U dijaloškom okviru koji se 
pojavi za formulu referenciramo polje B5 dok za input varijablu referenciramo B4, odnosno 
količinu. Time smo rekli da je količina varijabilna. Ono što će Calc sada napraviti je da će uzeti 
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svaku količinu navedenu u koloni D te nju ubaciti u formulu. Rezultat za različite količine će 
prikazati u koloni E. 

 

 

 

Tablice sa dvije ulazne varijable -> u ovom ćemo slučaju promatrati promjene količine i 
prodajne cijene te računati sukladno tome zaradu. 

U ćelije E1, F1, G1, H1 ćemo unijeti cijene 8, 10, 15, 20. Označimo raspon D1:H11 te odemo 
na Data -> Multiple Operations. U dijaloškom okviru unesemo formulu, te za Row input cell 
odaberemo onu sa cijenom (B1) jer smo cijene naveli u retku, a za Column input cell onu sa 
količinom (B4).  

 

 

Na ovaj način smo rekli da želimo da se prilikom računanja uzmu u obzir 2 varijable, odnosno 
iznos će se izračunavati na način da se za svaku količinu/cijenu ubace drugi podaci. Kao 
rezultat toga dobijemo tablicu sa svim mogućim varijacijama. Tako se u ćeliji F2 se nalazi 
zarada kada prodamo 500 komada po cijeni od 10 kn. 
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4.2 SORTIRANJE I FILTRIRANJE 

 

Sortirati podatke po više stupaca u isto vrijeme 

Najprije je potrebno odabrati podatke, te potom otići na Data -> Sort. 

U dijaloškom okviru potom unijeti redoslijed po kojem želite sortirati. 

 

 
 

Stvoriti prilagođeni popis i izvršiti prilagođeno sortiranje 

Kako bi stvorili prilagođeni popis otići na Tools -> Options -> LibreOffice Calc -> Sort Lists. 

U dijaloškom okviru kliknuti na Add te unijeti željeni redoslijed, od vrha prema dnu. 

 

 
Kako bi upotrijebili željeni prilagođeni popis, označiti ono što želite sortirati te otići na Data -
> Sort. U dijaloškom okviru otići na karticu Options te označiti Custom sort order te odabrati 
željeno sortiranje. 
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Automatski filtar 

Za primjer ćemo koristiti slijedeću tablicu. 

 

Učenik Matematika Hrvatski Rezultat 

Ana 85 87 zadovoljio 

Filip 50 77 zadovoljio 

Janko 72 22 nije zadovoljio 

Mirjana 24 12 nije zadovoljio 

 

Kako bi uključili automatsko filtriranje potrebno je označiti tablicu te otići na Data -> Filter -> 

AutoFilter. Kao rezultat toga će se pojaviti strelice prema dolje u zaglavlju svakog stupca. 
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Primijeniti opcije naprednog filtra na popisu 

Kada koristite napredni filtar, ne pojavljuje se strelice padajućeg izbornika već umjesto toga 
je potrebno unijeti kriterije u opseg kriterija. 

Ukoliko želimo primjerice samo vidjeti učenike koji imaju više od 50 bodova iz Matematike 
tada bi to definirali na slijedeći način: 

Matematika Matematika 

>50 <100 

Označimo tablicu u kojoj želimo izvršiti filtriranje te na kartici Data -> Filter -> Advanced 
Filter. 

Pojavit će se dijaloški okvir u kojeg zatim unosimo naše kriterije, odnosno u ovom slučaju u 
raspon kriterija uvezemo tablicu sa uvjetima koje smo malo prije definirali, te nakon toga 
kliknemo OK. 

 

 

 

Rezultat toga će biti tablica u kojoj će biti prikazani samo učenici koji ispunjavaju definirane 
kriterije. 

 

Učenik Matematika Hrvatski Rezultat 

Ana 85 87 zadovoljio 

Janko 72 22 nije zadovoljio 

 

 

Koristiti mogućnosti automatskog izračunavanja podzbrojeva  

Ukoliko u radnom listu imamo podatke o recimo prodaji različitih proizvoda, na jednostavan 
način možemo izračunati koliko je ukupno proizvoda prodano po vrsti proizvoda. Potrebno je 
označiti podatke te potom otići na Data -> Subtotals te u dijaloški okvir unijeti podatke 
sukladno željenim rezultatima. 

 



ITdesk.info – projekt računalne e-edukacije sa slobodnim pristupom 

ITdesk.info is licensed under a Creative Commons Attribution-  

Noncommercial-No Derivative Works 3.0 Croatia License   25/45 

 

 

 

 

 

 

4.3 SCENARIJI  

Scenarij je skup vrijednosti koje Calc sprema i može automatski zamijeniti u ćelijama na 
radnom listu. Na radnom listu možete stvoriti i spremiti različite grupe vrijednosti, a potom 
se prebaciti na bilo koji od tih novih scenarija da biste pogledali različite rezultate. 

 

Kreirati scenarij  

Označiti u tablici ćelije u kojima će se mijenjati vrijednosti te potom otići na Tools- > 
Scenarios, te pohraniti scenarij. 
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U ćelije za koje ste naveli da će se vrijednost mijenjati, sada možete unijeti neke druge 
vrijednosti i napraviti novi scenarij. 

 

 

 

U padajućem izborniku sada možete izabrati željeni scenarij i promatrati promjene. U ovom 
slučaju recimo ukupan broj prodanih proizvoda. 
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Prikazati, izmijeniti, izbrisati scenarije 

Scenarijima možete dalje upravljati preko Navigatora. 
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5. VREDNOVANJE I NADZOR 

5.1 VREDNOVANJE 
 

Postaviti, urediti kriterij vrednovanja za unos podataka u raspon ćelija kao što su cijeli broj, 

decimalni broj, popis, datum, vrijeme 

Kriterij vrednovanja: kriterij vrednovanja koristimo onda kada želimo da se u određenu 
ćeliju/e može unijeti određeni tip podatka (cijeli broj, datum, decimalni broj itd). Također je 
moguće ograničiti unos na vrijednosti koje su određenom intervalu, ili jednake nekoj 
vrijednosti, manje/veće od neke vrijednosti i slično. 

- Označite ćelije na koje se želi primijeniti određeni kriterij 

- Data -> Validity 

- Kada se pojavi dijaloški okvir unijeti željene postavke 

 

 
 

Unijeti ulaznu poruku i upozorenje o grešci 

Za unošenje ulazne poruke slijediti korake kao u prethodnoj uputi te potom kliknuti na 
karticu Input Help, te unijeti poruku sukladno kriterijima vrednovanja. Ta poruka će se 
prikazivati kada označite neku ćeliju za koju je definiran kriterij. 

Za unošenje upozorenja o grešci slijediti iste korake kao u prethodnoj uputi te potom kliknuti 
na Error Alert i unijeti tražene podatke. Ta poruka će se prikazivati kada se unese vrijednost 
koja ne zadovoljava zadani kriterij. 

 

 

5.2 NADZOR 
 

Prati prethodne, zavisne ćelije. Praćenje pogrešaka.  

Formule u Calc-u mogu sadržavati prethodnike i mogu služiti kao zavisne drugim formulama. 
Ćelija često služi i kao prethodna i kao zavisna. 

U svrhu nadzora na raspolaganju stoji Detective. 
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Kako bi vidjeli prethodnike potrebno je označiti ćeliju koja sadrži neku formulu, te otići na 
Tools -> Detective -> Trace Precedents. 

 

Na gornjoj slici je prikazano kako su ćelije B2:B7 prethodnici ćelije B8. Strelice prikazuje tijek 
informacija, odnosno sve vrijednosti se zbroje i rezultat je u ćeliji B8. 

Za praćenje zavisnih ćelija procedura je ista, samo je potrebno odabrati Tools -> Detective -> 
Trace Dependents. 

 

Iz slike se vidi kako je ćelija E10 ovisna o ćelijama B8 i B19. Odnosno, sve promjene koje se 
dese u tim ćelijama će se odraziti na ćeliju E10. 

Strelice se uklanjaju tko da se ode na Tools -> Detective -> Remove Precedents/Remove 
Dependants ili Remove All. 

Praćenje pogrešaka: Tools -> Detective -> Trace Errors. 

 

Pokazati sve formule na radnom listu, umjesto vrijednosti rezultata 

Tools -> Options -> LibreOffice Calc -> View -> označiti kućicu sa Formulas  
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Umetnuti, urediti, brisati, prikazati, sakriti komentare/bilješke 

 

Za umetanje, brisanje, prikaz, sakrivanje komentara dovoljno je označiti ćeliju te desni klik 
miša. Na izborniku koji se potom pojavi odabrati željenu radnju. 

Za uređivanje komentara dovoljno je dvaput kliknuti unutar komentara te izmijeniti sadržaj. 

 

Ćelije sa komentarom se mogu prepoznati po tome što se pojavi mali crveni kvadrat u 
gornjem desnom uglu ćelije. 
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6. POBOLJŠAVANJE PRODUKTIVNOSTI 

6.1 IMENOVANJE ĆELIJA 
 

Imenovati raspone ćelija, izbrisati imena za raspone ćelija 

Potrebno je odabrati ćeliju ili raspon ćelija kojima se želi dati naziv, te zatim kliknuti u okvir 
Naziv koji se nalazi na lijevom rubu trake formula. Unijeti željeni naziv te kliknuti ENTER. 

 

 

Druga opcija za definiranje naziva je preko kartice Insert -> Names -> Manager. Preko 
upravitelja je naziv moguće i obrisati. 

 

 

Koristiti imenovane raspone ćelija u funkcijama 

Imenovane raspone u funkcijama koristimo na jednostavan način, a taj je da umjesto da u 
funkciji navedemo raspon ćelija navedemo naziv. U slijedećem primjeru je ćelijama u kojima 
se nalaze količine dan naziv Količina, te u formuli za sumiranje je zatim umjesto raspona 
ćelija samo ubačen naziv Količina. 
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6.2 POSEBNO LIJEPLJENJE 
 

Koristiti opcije posebnog lijepljenja: zbroji, oduzmi, pomnoži, dijeli. 

Pomoću dijaloškog okvira Paste Special složene stavke se mogu kopirati iz radnog lista i 
zalijepiti u isti ili drugi radni list pomoću određenih atributa kopiranih podataka ili pomoću 
matematičke operacije koju želite primijeniti na kopirane podatke. 

U donjem primjeru u jednoj koloni imamo vrijednosti 1,2,3,4. Označimo te vrijednosti i 
kliknemo na Copy. Nakon toga označimo kolonu sa vrijednostima 5,6,7,8 i desnim klikom 
miša nam se otvori izbornik sa mogućnostima među kojima se nalazi i Paste special ( do 
Posebnog lijepljena možemo doći i preko glavnog izbornika Edit -> Paste Special). U 
izborniku Posebnog lijepljenja zatim odaberemo željenu radnju, primjerice Paste all  i Add.  
Nakon što kliknemo na OK u drugoj koloni ćemo dobiti zbrojene vrijednosti iz prve i druge 
kolone. Na isti način postižemo ostale operacije. 
 

 

 

Koristiti opcije posebnog lijepljenja: vrijednosti/brojevi, transponiraj 

Ukoliko želite kopirati samo brojeve/tekst/formule koji se nalaze u određenim ćelijama. 
Potrebno je odabrati željene ćelije i Copy. Tamo gdje želite ćelije kopirati kliknuti na desnu 
tipku miša te odabrati opciju Paste Only pa Text/Number/Formula, ovisno što želite 
kopirati. Na donjoj slici je prikazan rezultat odabira kopiranja samo brojeva. 
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- Transponiraj- Odaberete li ovo opciju, stupce kopiranih podataka mijenja u retke i 

obrnuto. Kao i u prethodnim slučajevima potrebno je odabrati željene ćelije pa Paste 

Special -> Transpose. 

 

6.3 PREDLOŠCI  
 

Napraviti radnu knjigu na temelju postojećeg predloška   

Otići na File -> New -> Template te u dijaloškom okviru koji se pojavi odabrati željeni 
predložak. 

 

 

Izmijeniti predložak  

U predlošcima možete raditi izmjene po želji, ili možete kreirati vlastiti predložak. Kada ste 
završili sa uređivanjem potrebno je predložak spremiti kako biste ga mogli opet koristiti. 

Otići na File -> Save as te u dijaloškom okviru koji se pojavi odabrati za Save as type -> ODF 
Spreadsheet Template. 

 

 

 
 

6.4 POVEZIVANJE, ULAGANJE I UVOZ 
 

Urediti, umetnuti, ukloniti hipervezu 

Za umetanje hiperveze označiti ćeliju u koju se želi ubaciti hiperveza te potom Insert -> 
Hyperlink. U dijaloškom prozoru koji se tada otvori odabrati željene postavke. Za uređivanje 
su koraci isti. Dakle, označiti ćeliju te otvoriti dijaloški okvir za hiperveze. 

Hiperveza se uklanja na način da se označi ćelija pa desni klik miša i Clear Direct Formating. 
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Povezati podatke u radnoj knjizi, između radnih knjiga, između aplikacija  

Povezivanje podataka u radnoj knjizi: 

- Referenciranje podataka se vrši preko formule =naziv_radnog_lista.naziv_ćelije. 

Ukoliko u neku ćeliju u radnom listu Sheet1 unesete =Sheet2.A1 time ste naveli da 

želite da ta ćelija sadrži podatke koji se nalaze u ćeliji A1 radnog lista Sheet2. Sve 

promjene koje se izvrše u referenciranoj ćeliji će se automatski preslikati u ćeliju u 

koju ste unijeli formulu. 

Povezivanje podataka između radnih knjiga: 

- Radnoj knjizi u koju želite unijeti referencu na neku drugu ćeliju označiti željenu ćeliju 

te unijeti =. Otići zatim u knjigu u kojoj se nalaze podaci koje želite referencirati te 

označiti ćeliju. Vratiti se u prvu radnu knjigu. Calc će automatski u ćeliju ubaciti 

referencu na označenu ćeliju. Referenca je oblika:  

='file:///C:/Users/Desktop/Untitled 1.ods'#Sheet2.A3 -> odnosno sadrži putanju do 

dokumenta kojeg se referencira te ime radnog lista i ćelije. 

Povezivanje podataka između aplikacija: 

- Kako bi se povezali podaci iz Calc-a i recimo Open Libre Writera koristi se DDE, 

odnosno Dynamic Data Exchange. DDE omogućava preslikavanje informacija u 

stvarnom vremenu, gdje se sve promjene koje se naprave u Calc radnom listu 

automatski prenose na Writer dokument. 

- Označiti ćelije koje se želi povezati te odabrati Copy. 

- U Writer dokumentu odabrati Paste special, te u dijaloškom okviru koji se pojavi 

odabrati DDE link. 
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- Sve promjene koje sada napravite u Calc radnom listu će se automatski ažurirati u 

Writer dokumentu. 

 

Uvoz razgraničenih podataka iz tekstualne datoteke 

Razgraničene datoteke su datoteke koje sadrže podatke odvojene zarezima, tabulatorima, i 
slično. 

Ukoliko imam primjerice tekstualnu datoteku u kojoj su podaci spremljeni na način da su 
odvojeni točka-zarezom (1;2;3;4;5) te podatke možemo uvesti u Calc na način da odemo na 
File -> Open te odaberemo željenu datoteku. 

Otvorit će se dijaloški okvir u kojem možemo primjerice definirati na koji su način 
razgraničeni podaci (Separated by). 

 

 

Po završetku će podaci biti uvezeni u Calc radni list. 
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6.5 AUTOMATIZACIJA 
 

Kreirati makronaredbe kao što su promjena postavki stranice, primjena prilagođenog 

oblika broja, primjena automatskog oblikovanja na raspon ćelija, umetanje polja u 

zaglavlje, podnožje radnog lista 

Makronaredbe omogućavaju snimanje određenih koraka koje potom možete izvršiti 
jednostavnim pokretanjem makronaredbe koja će onda za vas napraviti snimljene korake. 

Kako bi se uključila mogućnost izrade makro naredbi potrebno je najprije otići na Tools -> 
Options -> LibreOffice -> Advanced te označiti kućicu ispred Enable macro recording. 

Kada želite početi snimati otići na Tools -> Macros  -> Record macro. Pojavit će dijaloški okvir 
u kojeg možete kliknuti kako biste na kraju zaustavili snimanje. 

 

 

 

Po završetku snimanje otvorit će se dijaloški okvir u kojem unosite ime za svoj macro. 

 

 

Pokrenuti makronaredbu 

Otići na Tools -> Macros -> Run macro. Otvorit će se dijaloški okvir iz kojeg onda odaberete 
makronaredbu koju želite pokrenuti te kliknite na Run.  
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Dodijeliti makronaredbu gumbu na alatnoj traci  

Odabrati View -> Toolbars -> Customize, te potom kliknuti na Add. 

 

 

U dijaloškom okviru koji se potom otvori kliknuti na Add te odabrati željeni macro. Macro će 
se pojaviti na alatnoj traci. 
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7. SURADNIČKO UREĐIVANJE 

7.1 PRAĆENJE I PREGLEDAVANJE 
 

Uključiti, isključiti praćenje promjena. Praćenje promjena na radnom listu pomoću okna za 

pregled. 

Kako bi omogućili praćenje promjena potrebno je najprije otići na File -> Properties -> 
Security te označiti kućicu ispred Record changes. Također je potrebno omogućiti dijeljenje 
dokumenta na način da se ode na Tools -> Share document  te označiti kućicu ispred Share 
this spreadsheet with other users. 

Kada dođe do promjene unutar neke ćelije ta ćelija dobije crveni rub te pozicioniranjem na 
tu ćeliju se prikaže poruka sa opisom promjene. 

 

 

Prikaz svih promjena možete dobiti tako da odete na Edit -> Changes -> Show. U dijaloškom 
okviru koji se zatim pojavi možete filtrirati koje promjene želite vidjeti (po datumu, autoru i 
slično). 

 

 

Praćenje promjena se može isključiti preko Edit -> Changes -> Record. 

 

Prihvatiti, odbaciti promjene na radnom listu 

Otići na Edit -> Changes -> Accept or reject. Pojavit će se popis svih promjena koje 
jednostavno možete prihvatiti klikom na Accept ili odbaciti klikom na Reject. 
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Usporediti i spojiti radne knjige 

Otvoriti originalni dokument te otići na Edit -> Changes -> Merge document. 

Otvorit će se dijaloški okvir u kojem morate odabrati kopiju dokumenta kojeg želite spojiti. 
Kliknuti potom na Open. 

Po spajanju dokumenata pojavit će se Accept or Reject Changes dijaloški okvir u kojem će biti 
prikazane promjene. Na način kako je opisano u prethodnom odjeljku možete sada prihvatiti 
ili odbaciti promjene. 

Obzirom da se može desiti da netko zaboravi zabilježiti svoje promjene, moguće je 
dokumente usporediti preko Edit -> Compare Document.  

- Otvoriti izmijenjeni dokument kojeg želite usporediti sa originalnim dokumentom 

- Edit -> Compare Document 

- U dijaloškom okviru koji se pojavi odabrati originalni dokument 

- U ovom trenutku će u dokumentu biti označene sve izmjene koje možete potom 

zadržati ili odbaciti po želji. 

 

 

7.2 ZAŠTITA 

 

Dodati, ukloniti lozinku za zaštitu radne knjige: otvaranje, izmjene 

Zaštita radne knjige štiti strukturu dokumenta. Ukoliko je uključena onemogućuje 
ubacivanje, brisanje, preimenovanje, premještanje ili kopiranje radnih listova. Za uključivanje 
je potrebno otići na Tools -> Protect Document -> Document. 

U dijaloški okvir koji se potom pojavi moguće je dodati lozinku (nije obavezno). 
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Za uklanjanje lozinke opet otići na Tools -> Protect Document -> Document te unijeti lozinku. 

 

 

 

 

Zaštita, uklanjanje zaštite ćelija, radnih listova korištenjem lozinke 

Ćelije se može zaštiti na način da se ode na Format -> Cells, te se u dijaloškom okviru u 
kartici Cell Protection označi kućica ispred Protected. 

 

 

Ćelije su zaštićene samo onda kada je zaštićen i radni list. 

Za zaštitu radnog lista otići na Tools -> Protect Document -> Sheet.  U dijaloškom okviru koji 
se zatim pojavi možete definirati lozinku. 
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Za uklanje zaštite radnog lista otići opet na Tools -> Protect Document -> Sheet te unijeti 
lozinku. 

 

 

 

 

Sakriti, otkriti formule 

Najprije otići na Format -> Cells te u dijaloškom okviru u kartici Cell Protection označiti 
kućicu ispred Hide formula. 

 

Nakon toga je potrebno uključiti zaštitu radnog lista kako je to ranije objašnjeno. Po zaštiti 
radnog lista formule više neće biti prikazane. 

 

Radni list bez skrivanja formula: 
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Radni list sa skrivenim formulama: 
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Ovaj priručnik je namijenjen za učenje uz materijale 

objavljene na sljedećim linkovima: 

 

Pomoću kvizeva objavljenih na linkovima ispod testirajte poznavanje naprednog rada sa 

tabličnim kalkulacijama u programu Microsoft Excel 2010 (pripremio i izradio: Mario 

Dujlo): 

Uređivanje podataka i prikaza: 

Imenovati ćelije/područja ćelija na radnom listu 

Primijeniti automatsko oblikovanje na području ćelija 

Kreirati korisnički oblik broja 

Upotrijebiti mogućnosti uvjetnog oblikovanja i posebnog lijepljenja 

Uvesti tekstualnu datoteku razgraničenu zarezom, razmakom ili tabulatorom 

Zamrznuti naslove redaka i/ili stupaca 

Sakriti / otkriti retke ili stupce ili radne listove 

Upotrijebiti mogućnosti podzbrojeva 

Upotrijebiti tablice podataka s jednom ili dvije varijable / „Što ako“ tablice 

pokreni 

kviz  

Zaštita i sigurnost: 

Zaštititi / ukloniti zaštitu radnog lista lozinkom 

Zaštititi / ukloniti zaštitu lozinkom označenih ćelija na radnom listu 

Dodati i ukloniti lozinku radnoj knjizi 

Razvrstavanje podataka: 

Razvrstati podatke po kriterijima u više stupaca; 

Izvesti sortiranje prema vlastitim podacima 

Upiti / Filtri: 

Kreirati upit s jednim ili više kriterija koristeći dostupne mogućnosti 

Upotrijebiti mogućnosti naprednih upita / filtriranja 

 
pokreni 

kviz  

Povezivanje podataka: 

Povezati podatke / grafikon unutar radnog lista 

Povezati podatke / grafikon između radnih listova 

Povezati podatke / grafikon između radnih knjiga 

Povezati podatke / grafikon sa dokumentom aplikacije za obradu teksta 

Konsolidirati podatke u susjednim radnim listovima pomoću 3D sum funkcije 

Predlošci: 

Upotrijebiti predložak; urediti predložak 

Grafikoni: 

Promijeniti kut kriški u tortnom dijagramu; 

Oblikovati tekst ili brojeve na osima grafikona; 

Promijeniti položaj naslova, legende ili oznaka podataka na grafikonu; 

„Razrezati“ (explode) sve segmente tortnog grafikona; 

Obrisati skup podataka iz grafikona; 

Promijeniti tip grafikona za zadani skup podataka; 

Povećati razmak između stupaca / položenih stupaca u 2D grafikonu; 

Umetnuti sliku u 2D grafikon 

pokreni 

kviz  

http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-podaci-i-prikaz-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-podaci-i-prikaz-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-sigurnost-razvrstavanje-i-upiti-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-sigurnost-razvrstavanje-i-upiti-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-sigurnost-razvrstavanje-i-upiti-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-sigurnost-razvrstavanje-i-upiti-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-povezivanje-predlosci-i-grafikoni-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-povezivanje-predlosci-i-grafikoni-kviz/
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Poboljšanje produktivnosti: 

Imenovanje raspona ćelija 

Posebno ljepljenje 

Napredno oblikovanje: 

Primijeniti automatsko oblikovanje/stil tablice na raspon ćelija. 

Primijeniti uvjetno oblikovanje bazirano na temelju sadržaja ćelija. 

Kreirati i primijeniti prilagođeno oblikovanje brojeva. 

Uvoz razgraničenih podataka iz tekstualne datoteke. 

pokreni 

kviz 

Upotreba funkcija: 

Upotrijebiti funkcije datuma i vremena: TODAY; DAY; MONTH; YEAR 

Upotrijebiti matematičke funkcije: SUMIF; SUMPOSITIVE; ROUND 

Upotrijebiti statističke funkcije: COUNT; PURECOUNT; COUNTA; COUNTIF 

Upotrijebiti funkcije za tekst: PROPER; UPPER; LOWER; CONCATENATE 

Upotrijebiti financijske funkcije: FV; NPV; PMT; PV; RATE 

Upotrijebiti funkcije za referenciranje i pretraživanje: HLOOKUP; VLOOKUP 

Upotrijebiti logičke funkcije: IF; AND; OR; ISERROR 

Upotrijebiti dostupne funkcije baze podataka: DSUM; DMIN; DMAX; DCOUNT 

Upotrijebiti ugniježđene (nested) funkcije 

pokreni 
kviz  

Analiza – Zaokretna tablica (Pivot Table): 

Kreirati zaokretnu tablicu pomoću definiranih imena polja 

Izmijeniti izvor podataka i osvježiti zaokretnu tablicu 

Grupirati / prikazati podatke u zaokretnoj tablici prema zadanom uvjetu 

Analiza - Scenariji / Verzije: 

Kreirati imenovane scenarije / verzije na osnovu zadanih područja ćelija 

Kreirati sažetak scenarija (Scenario summary) / izvješće verzija (Version report) 

Analiza - Nadzor formula (Auditing): 

Praćenje prethodnih ćelija na radnom listu 

Praćenje zavisnih ćelija na radnom listu; 

Prikazati sve formule ili vidjeti lokacije svih formula na radnom listu; 

Dodati ili ukloniti komentare na radnom listu; 

Urediti komentare na radnom listu 

Posebni alati – Makronaredbe: 

Snimiti jednostavnu makronaredbu (npr. promjena postavki stranice); 

Pokrenuti makronaredbu; 

Dodijeliti makronaredbu gumbu na alatnoj traci 

pokreni 
kviz  

 

 

 

 

  

http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-imenovanje-raspona-celija-posebno-ljepljenje-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-imenovanje-raspona-celija-posebno-ljepljenje-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-upotreba-funkcija-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-upotreba-funkcija-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-analiza-i-posebni-alati-kviz/
http://www.itdesk.info/hr/e-edukacija/modul-4-tablicne-kalkulacije/naprednije-tablicne-kalkulacije-analiza-i-posebni-alati-kviz/
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8. OPĆI UVJETI KORIŠTENJA 

Web–stranicu www.ITdesk.info je pokrenula udruga „Otvoreno društvo za 
razmjenu ideja - ODRAZI“ u sklopu aktivnog promoviranja ljudskog prava na 
slobodan pristup informacijama te ljudskog prava na edukaciju. 

Slobodno kopirajte i distribuirajte ovaj dokument, uz uvjet da ne mijenjate ništa u 
njemu! 

Nad svim programima i uslugama navedenim na web–stranici ITdesk Home na web adresi ITdesk.info 
isključivo pravo posjeduju njihovi autori/ce. Microsoft, Windows, i Windowsxx su registrirani zaštitni 
znakovi tvrtke Microsoft Corporation. Ostali zaštitni znaci korišteni na ITdesk Home web-stranicama 
su isključivo vlasništvo njihovih vlasnika/ca. Ako imate pitanja vezana uz uporabu ili redistribuciju bilo 
kojeg programa, molimo kontaktirajte autore/ice dotičnog programa. Sva dodatna pitanja pošaljite 
na info@itdesk.info.  

___________________________________ 

Ove web–stranice sadržavaju linkove na ostale web–stranice ili izvore. ITdesk.info tim NIJE odgovoran 
za tekstualni i/ili reklamni sadržaj, odnosno za proizvode koji su na tim web–stranicama /izvorima 
ponuđeni, kao što NIJE odgovoran niti za sadržaj koji je putem njih dostupan; mogućnost korištenja ili 
točnost sadržaja. Linkove koristite na vlastitu odgovornost. Također, ITdesk.info tim ne garantira: 

 da je sadržaj na ovim web–stranicama oslobođen od pogrešaka ili pogodan za svaku svrhu, 

 da će ove web–stranice ili web usluge funkcionirati bez pogrešaka ili prekida, 

 da će biti odgovarajući za vaše potrebe, 

 da implementacija takvog sadržaja neće narušavati patente, autorska prava, zaštitni znak ili 
ostala prava neke treće strane. 

Ako se ne slažete s ovim općim uvjetima korištenja ili ako niste zadovoljni web–stranicama koje 
pružamo, prekinite s korištenjem ovih web–stranica i web usluga. ITdesk.info tim nije odgovoran 
vama, niti trećim osobama za bilo koju nastalu štetu, bila ona direktna, indirektna, slučajna ili 
posljedična, povezana s ili proizlazeći iz vaše uporabe, pogrešne uporabe ovih web–stranica ili web 
usluga. Iako vaše potraživanje može biti bazirano na garanciji, ugovoru, prekršaju ili nekom drugom 
pravnom uporištu, neovisno o našoj obaviještenosti o mogućnosti nastanka takve štete, oslobađamo 
se svake odgovornosti. Prihvaćanje ograničenja naše odgovornosti nužan je preduvjet korištenja ovih 
web–stranica i web usluga 

Svi softveri navedeni u ovom ili drugim dokumentima objavljenim na stranici ITdesk.info su navedeni 
samo za edukativne svrhe ili kao primjer te mi, na bilo koji način, ne preferiramo navedeni softver u 
odnosu na neki drugi softver. Bilo koju izjavu da neki navedeni softver preferiramo više u odnosu na 
drugi, koji se spominje ili ne spominje u materijalima, smatrat će se kao lažni iskaz. Našu izravnu i 
bezrezervnu podršku imaju jedino softveri otvorenog koda (open source) koji omogućuju 
korisnicima/cama da bez prepreka postanu digitalno pismeni, koriste računalo i sudjeluju u 
modernom informatičkom društvu. 

 

 

 

 

http://www.itdesk.info/
mailto:info@itdesk.info
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Nakladnik: 
Otvoreno društvo za razmjenu ideja  
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